1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Autofill problem - urgent!

Discussion in 'Professional Support' started by rbuelund, Oct 21, 2014.

  1. rbuelund

    rbuelund Member

    Level: Community
    No prefilter is set - as I wrote earlier - this worked 3 weeks ago, before i updated Joomla - I have touched nothing in fabrik.
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    Updated Joomla from which version?
    Any other changes (e.g. php version, Joomla template,...)?

    You may check:
    id elements published and selected as PK in list settings?
    open/resave your Fabrik connection (do you have multiple ones?)
     
  3. rbuelund

    rbuelund Member

    Level: Community
    I think I updated from 3.3.3 to 3.3.6

    id's are all ok.
    I only have one connection - resaving does not change anything.
     
  4. troester

    troester Well-Known Member Staff Member

    Level: Community
    Do you have anything in trash (lists, elements, connections!)?
     
  5. rbuelund

    rbuelund Member

    Level: Community
    No - nothing in trash
     
  6. rbuelund

    rbuelund Member

    Level: Community
    I can see that the inserted javascript is this:

    var autofill = new Autofill({"observe":"xxxxxx_fabriktable_bonusskema___student","trigger":"","formid":2,"map":"{\"xxxxxx_fabriktable_bonusskema_student___department\":\"xxxxxx_fabriktable_bonusskema___department_foreign\",\"xxxxx_fabriktable_bonusskema_student___birthday\":\"xxxxxx_fabriktable_bonusskema___birthday_foreign\"}","cnn":"1","table":"1","editOrig":false,"confirm":false,"autofill_lookup_field":null,"fillOnLoad":false});
    });

    I think it looks allright. I really don't see what the problem is. Also I see no javascript conflicts on the site - please help.
     
  7. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I'm still unable to login. You've removed the hostname from your My Sites info, so I'm going by what my browser is remembering as the URL, based on the holmenside/ path. See this screencast. I've tried copying and pasting the password from your My Sites info, typing it by hand, and using Last Pass (which has the creendtials from the last time I successfully logged in).

    [deleted screencast]

    Let me know as soon as you've watched the cast, and I'll remove it from this post.

    -- hugh
     
  8. rbuelund

    rbuelund Member

    Level: Community
    Hi - I've seen it. I have corrected the URL in My sites (I think you are trying to login on my testsite) - the URL was missing a ".dk" - please try again,
     
  9. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Now it just redirects to the non-admin home page when I hit that URL.
     
  10. rbuelund

    rbuelund Member

    Level: Community
    You have to go into the mysites settings and copy paste the url - there is some serucity that is obviously being removed in the link you are using. I think it is because the http:// in front is missing in the link.

    ..or you can simplyt copy the link you are using and paste into the browser - then it works,
     
  11. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    OK, I was finally able to login.

    It seems to be an issue with the grouping on the Students table. Don't know why the J! upgrade would have broken things, I'm looking at that now. Meanwhile, I've turned off grouping on your Students table, while I work out the fix for that locally, which allows the autofill to work again.

    -- hugh
     
  12. rbuelund

    rbuelund Member

    Level: Community
    Ok - but i need the grouping to work also
     
  13. rbuelund

    rbuelund Member

    Level: Community
    Please write as soon as you're finished - because i have to manually edit all post the last 4 weeks to get this to work again - best before tomorrow ! :-(
     
  14. rbuelund

    rbuelund Member

    Level: Community
    Could you eventually tell me if this is gonna work to update the missing fields in the database:

    For the department_foreign column:
    update XXXXXX_fabriktable_bonusskema, XXXXXX_fabriktable_student
    set XXXXXX_fabriktable_bonusskema.department_foreign=XXXXXX_fabriktable_bonusskema_student .department
    where XXXXXX_fabriktable_bonusskema_student .id =XXXXXX_fabriktable_bonusskema.student;
     
  15. rbuelund

    rbuelund Member

    Level: Community
    I tried the above sql out, and it worked. But has the problem been fixed or ?
     
  16. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I think I have a fix for the grouping issue locally, I'm testing it.

    -- hugh
     
  17. rbuelund

    rbuelund Member

    Level: Community
    OK - what created the problem ?
     
  18. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
  19. rbuelund

    rbuelund Member

    Level: Community
    I can see that you have corrected it on my site, so must i update ? Are you finnished working on the site?
     
  20. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I've applied the fix on your site, and re-applied grouping on your Students table, seems to work now.

    I really don't know what broke it. Something to do with a change in the guts of the J! database API. I'm still trying to work that out, so I can anticipate any other issues it may cause us. The workaround for the autofill was a kind of bandaid, to get you going again.

    -- hugh
     

Share This Page